Discover Zigbee and Z-Wave Devices

From Hubitat Documentation
Jump to: navigation, search

Discovering Your Devices

Discovering Devices is the process for pairing your Zigbee and Z-Wave mesh devices. Other devices, such as Lutron and Hue, are connected using integration apps which can be found in the Apps section of your Web Interface. Remember as you connect Zigbee and Z-Wave devices that they have a limited range and if they are too far from your hub you may need to add repeating devices (devices that plug in to the wall) to make the connection.

Here's how to Discover your devices:

  1. Put your device in pairing mode (See the manufacturer’s instructions, but it probably involves pressing a small, inconvenient button a couple times).
  2. Choose the Discover Devices link in your Hubitat Web Interface home page or from the kabob menu at the top right.
    Discover Zigbee and Z-Wave Devices 2.0.png
  3. Choose the type of supported device you want to connect to your hub. Hubitat Elevation™ will attempt to discover your device. Within a few seconds your Hubitat Elevation™ should discover your device. Found devices will appear in the lower left of the window, where a custom label may be added before selecting Save.
    Device Discovery 2.0.9.png
  4. Select Save

Your device is now added to your hub. Now you can manage your device, automate it or add it to your dashboard. The discovery process times out after 60 seconds if no devices is found. If your device did not pair in the time, try putting your device in pairing mode again for Zigbee devices, or Inclusion mode for Z-Wave and select Restart to attempt discovery again.

TROUBLE SHOOTING If your device does not pair, here are some potential culprits:Is your device compatible? Hubitat Elevation™ includes Z-Wave and Zigbee radios that work with a wide variety of Zigbee and Z-Wave devices. Check this list of known compatible devices. Devices running on different protocols, such as Lutron and Hue, require a bridge that must be paired using an integration app.

  1. Is your device out of range? Z-wave and Zigbee radios have a limited range that is further reduced by obstructions, included metal, wood and drywall. It is important to build out a mesh network that includes plugged-in devices that act as repeaters and boost the range and signal strength of your hub.
  2. Is this a Z-Wave device from another hub? Unless it is a new device, Z-Wave devices must be excluded from their previous hub before they can be joined with a new hub. Ideally you should also perform a factory reset before attempting to join it to the new Z-Wave network. If the procedure to factory reset is not available, then you should at least perform device exclusion. To do this you will need to open up your old hub UI and follow the Z-Wave exclude procedure. Anytime you want to remove a Z-Wave device it is important run a Z-Wave exclude first.
  3. Is your device in pairing mode? All devices are different. Check the device manual to make you have followed the proper procedure to put it in pairing mode.
  4. Did your Z-Wave device fail to be included properly? Run a general Z-Wave exclusion, then try pairing again.
  5. Is the device battery dead? Try pairing with a fresh battery.
  6. Are there Zigbee bulbs interfering? Certain Zigbee bulbs may interfere with the routing of the Zigbee network traffic. If you're having trouble with Zigbee device discovery, try temporarily removing nearby bulbs to see if this alleviates the issue.